using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[^ ]|[^ ] [^ ])+)(?: +|$)";
string input = @"aaaaa
aa aa a
aaa aaa
aa aa aaa
aaaa aaa
aa aa aa aa aa a
field1 field 2 field 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}