// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[^ ]|[^ ] [^ ])+)(?: +|$)").unwrap();
let string = "aaaaa
aa aa a
aaa aaa
aa aa aaa
aaaa aaa
aa aa aa aa aa a
field1 field 2 field 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}