$re = '/((?:[^ ]|[^ ] [^ ])+)(?: +|$)/m';
$str = 'aaaaa
aa aa a
aaa aaa
aa aa aaa
aaaa aaa
aa aa aa aa aa a
field1 field 2 field 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);