import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[^ ]|[^ ] [^ ])+)(?: +|$)";
final String string = "aaaaa\n"
+ "aa aa a\n"
+ "aaa aaa\n"
+ "aa aa aaa\n"
+ "aaaa aaa\n"
+ "aa aa aa aa aa a\n"
+ "field1 field 2 field 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}