const regex = /((1?\d(?::\d\d)?(?: [ap]\.m\.)?)(?:-(?2))?)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((1?\\d(?::\\d\\d)?(?: [ap]\\.m\\.)?)(?:-(?2))?)', 'gi')
const str = `9:30-11 a.m. asdflkj; 12-8 p.m. 2:30-4:30 p.m. as;dlfkj 8 p.m. asdf;lkj 7-11 p.m. 11 a.m.-1 p.m. asd;lfkj 11 a.m. asd;flkj 7-10:30 p.m. and 8 p.m.-12 a.m.
asdf;lkj 12:30-2:30 p.m. a;lsdfj 12:15 p.m. a;ljkf 7 p.m.-12 a.m. 9:30-11:30 a.m.
8:00 a.m.-12:45 p.m.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}