re = /((1?\d(?::\d\d)?(?: [ap]\.m\.)?)(?:-(?2))?)/i
str = '9:30-11 a.m. asdflkj; 12-8 p.m. 2:30-4:30 p.m. as;dlfkj 8 p.m. asdf;lkj 7-11 p.m. 11 a.m.-1 p.m. asd;lfkj 11 a.m. asd;flkj 7-10:30 p.m. and 8 p.m.-12 a.m.
asdf;lkj 12:30-2:30 p.m. a;lsdfj 12:15 p.m. a;ljkf 7 p.m.-12 a.m. 9:30-11:30 a.m.
8:00 a.m.-12:45 p.m.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end