use strict;
my $str = '9:30-11 a.m. asdflkj; 12-8 p.m. 2:30-4:30 p.m. as;dlfkj 8 p.m. asdf;lkj 7-11 p.m. 11 a.m.-1 p.m. asd;lfkj 11 a.m. asd;flkj 7-10:30 p.m. and 8 p.m.-12 a.m.
asdf;lkj 12:30-2:30 p.m. a;lsdfj 12:15 p.m. a;ljkf 7 p.m.-12 a.m. 9:30-11:30 a.m.
8:00 a.m.-12:45 p.m.';
my $regex = qr/((1?\d(?::\d\d)?(?: [ap]\.m\.)?)(?:-(?2))?)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}