using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr bgcolor=""#d3ebf8""><td>.*?</td><td>(.*?)</td><td>.*?</td></tr>";
string input = @"<tr bgcolor=""#d3ebf8""><td>Albacom</td><td>relay.albacom.net</td><td></td></tr><tr bgcolor=""#d3ebf8""><td>Albacom</td><td>smtp.albacom.net</td><td></td></tr>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}