import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr bgcolor=\"#d3ebf8\"><td>.*?</td><td>(.*?)</td><td>.*?</td></tr>";
final String string = "<tr bgcolor=\"#d3ebf8\"><td>Albacom</td><td>relay.albacom.net</td><td></td></tr><tr bgcolor=\"#d3ebf8\"><td>Albacom</td><td>smtp.albacom.net</td><td></td></tr>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}