re = /<tr bgcolor="#d3ebf8"><td>.*?<\/td><td>(.*?)<\/td><td>.*?<\/td><\/tr>/
str = '<tr bgcolor="#d3ebf8"><td>Albacom</td><td>relay.albacom.net</td><td></td></tr><tr bgcolor="#d3ebf8"><td>Albacom</td><td>smtp.albacom.net</td><td></td></tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end