// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"<tr bgcolor="#d3ebf8"><td>.*?</td><td>(.*?)</td><td>.*?</td></tr>"##).unwrap();
let string = "<tr bgcolor=\"#d3ebf8\"><td>Albacom</td><td>relay.albacom.net</td><td></td></tr><tr bgcolor=\"#d3ebf8\"><td>Albacom</td><td>smtp.albacom.net</td><td></td></tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}