import re
regex = re.compile(r"<tr bgcolor=\"#d3ebf8\"><td>.*?</td><td>(.*?)</td><td>.*?</td></tr>")
test_str = "<tr bgcolor=\"#d3ebf8\"><td>Albacom</td><td>relay.albacom.net</td><td></td></tr><tr bgcolor=\"#d3ebf8\"><td>Albacom</td><td>smtp.albacom.net</td><td></td></tr>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")