using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Member:\n(?: .*\n|\n)*?(^ *Security ID:[^$\n]*$)";
string input = @"A member was added to a security-enabled global group
Subject:
Security ID: ...xxx
Account Name: ...
Account Domain: ...
Logon ID: ...
Member:
a line <--
a second line, indented by two spaces
Security ID: ...xbfdfdh
other line
Account Name: ...
Group:
Security ID: ...
Group Name: ...
Group Domain: ...
Additional Information:
...
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}