const regex = /Member:\n(?: .*\n|\n)*?(^ *Security ID:[^$\n]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Member:\\n(?: .*\\n|\\n)*?(^ *Security ID:[^$\\n]*$)', 'gm')
const str = `A member was added to a security-enabled global group
Subject:
Security ID: ...xxx
Account Name: ...
Account Domain: ...
Logon ID: ...
Member:
a line <--
a second line, indented by two spaces
Security ID: ...xbfdfdh
other line
Account Name: ...
Group:
Security ID: ...
Group Name: ...
Group Domain: ...
Additional Information:
...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}