$re = '/Member:\n(?: .*\n|\n)*?(^ *Security ID:[^$\n]*$)/m';
$str = 'A member was added to a security-enabled global group
Subject:
Security ID: ...xxx
Account Name: ...
Account Domain: ...
Logon ID: ...
Member:
a line <--
a second line, indented by two spaces
Security ID: ...xbfdfdh
other line
Account Name: ...
Group:
Security ID: ...
Group Name: ...
Group Domain: ...
Additional Information:
...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);