import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Member:\\n(?: .*\\n|\\n)*?(^ *Security ID:[^$\\n]*$)";
final String string = "A member was added to a security-enabled global group\n\n"
+ "Subject:\n"
+ " Security ID: ...xxx\n"
+ " Account Name: ...\n"
+ " Account Domain: ...\n"
+ " Logon ID: ...\n"
+ "Member:\n"
+ " a line <--\n\n"
+ " a second line, indented by two spaces\n"
+ " Security ID: ...xbfdfdh\n"
+ " other line\n"
+ " Account Name: ...\n"
+ "Group:\n"
+ " Security ID: ...\n"
+ " Group Name: ...\n"
+ " Group Domain: ...\n"
+ "Additional Information:\n"
+ " ...\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}