re = /Member:\n(?: .*\n|\n)*?(^ *Security ID:[^$\n]*$)/m
str = 'A member was added to a security-enabled global group
Subject:
Security ID: ...xxx
Account Name: ...
Account Domain: ...
Logon ID: ...
Member:
a line <--
a second line, indented by two spaces
Security ID: ...xbfdfdh
other line
Account Name: ...
Group:
Security ID: ...
Group Name: ...
Group Domain: ...
Additional Information:
...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end