#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\+([0-9]{1,4})(?:\s?)\(([0-9]{1,6})\)(?:\s?)([ 0-9]{1,15})(?:\s?)(?:\-?)(?:\s?)([ \-0-9]{1,10})?(?:\s?)"
Local $sString = "+49 (461) 127011" & @CRLF & _
"+9 (461) 127 011 -123" & @CRLF & _
"+49 (461) 127 011 123" & @CRLF & _
"+49 (461) 127011-0" & @CRLF & _
"+49 (461) 127011-123" & @CRLF & _
"+49 (461) 127-011-123" & @CRLF & _
"+49 (461) 127 011 123" & @CRLF & _
"+49 (461) 12701 1" & @CRLF & _
"+001 (46111) 127011-00" & @CRLF & _
"+43 (461123) 12-123" & @CRLF & _
"+49 46111 127011-0" & @CRLF & _
"+49 46111 1270110"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)