// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\+([0-9]{1,4})(?:\s?)\(([0-9]{1,6})\)(?:\s?)([ 0-9]{1,15})(?:\s?)(?:\-?)(?:\s?)([ \-0-9]{1,10})?(?:\s?)").unwrap();
let string = "+49 (461) 127011
+9 (461) 127 011 -123
+49 (461) 127 011 123
+49 (461) 127011-0
+49 (461) 127011-123
+49 (461) 127-011-123
+49 (461) 127 011 123
+49 (461) 12701 1
+001 (46111) 127011-00
+43 (461123) 12-123
+49 46111 127011-0
+49 46111 1270110";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}