# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\+([0-9]{1,4})(?:\s?)\(([0-9]{1,6})\)(?:\s?)([ 0-9]{1,15})(?:\s?)(?:\-?)(?:\s?)([ \-0-9]{1,10})?(?:\s?)"
test_str = ("+49 (461) 127011\n"
"+9 (461) 127 011 -123\n"
"+49 (461) 127 011 123\n"
"+49 (461) 127011-0\n"
"+49 (461) 127011-123\n"
"+49 (461) 127-011-123\n"
"+49 (461) 127 011 123\n"
"+49 (461) 12701 1\n"
"+001 (46111) 127011-00\n"
"+43 (461123) 12-123\n"
"+49 46111 127011-0\n"
"+49 46111 1270110")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.