import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+([0-9]{1,4})(?:\\s?)\\(([0-9]{1,6})\\)(?:\\s?)([ 0-9]{1,15})(?:\\s?)(?:\\-?)(?:\\s?)([ \\-0-9]{1,10})?(?:\\s?)";
final String string = "+49 (461) 127011\n"
+ "+9 (461) 127 011 -123\n"
+ "+49 (461) 127 011 123\n"
+ "+49 (461) 127011-0\n"
+ "+49 (461) 127011-123\n"
+ "+49 (461) 127-011-123\n"
+ "+49 (461) 127 011 123\n"
+ "+49 (461) 12701 1\n"
+ "+001 (46111) 127011-00\n"
+ "+43 (461123) 12-123\n"
+ "+49 46111 127011-0\n"
+ "+49 46111 1270110";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}