import Foundation
let pattern = #"\+([0-9]{1,4})(?:\s?)\(([0-9]{1,6})\)(?:\s?)([ 0-9]{1,15})(?:\s?)(?:\-?)(?:\s?)([ \-0-9]{1,10})?(?:\s?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+49 (461) 127011
+9 (461) 127 011 -123
+49 (461) 127 011 123
+49 (461) 127011-0
+49 (461) 127011-123
+49 (461) 127-011-123
+49 (461) 127 011 123
+49 (461) 12701 1
+001 (46111) 127011-00
+43 (461123) 12-123
+49 46111 127011-0
+49 46111 1270110
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)