#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\babc(?:,(?!02,)[^,;\n]+)*,01;"
Local $sString = "input1: "abc,clutter,01;xyz,clutter,02;" (should match)" & @CRLF & _
"input2: "abc,clutter,02;zyz,clutter,01;" (no match)" & @CRLF & _
"input3: "abc,clutter,02;abc,abc,txt,txt,01;xyz,clutter,01" (should match)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"abc,zyz,01,clutter,01;" & @CRLF & _
"abc,zyz,02,clutter,01;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")