$re = '/\babc(?:,(?!02,)[^,;\n]+)*,01;/m';
$str = 'input1: "abc,clutter,01;xyz,clutter,02;" (should match)
input2: "abc,clutter,02;zyz,clutter,01;" (no match)
input3: "abc,clutter,02;abc,abc,txt,txt,01;xyz,clutter,01" (should match)
abc,zyz,01,clutter,01;
abc,zyz,02,clutter,01;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);