using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\babc(?:,(?!02,)[^,;\n]+)*,01;";
string input = @"input1: ""abc,clutter,01;xyz,clutter,02;"" (should match)
input2: ""abc,clutter,02;zyz,clutter,01;"" (no match)
input3: ""abc,clutter,02;abc,abc,txt,txt,01;xyz,clutter,01"" (should match)
abc,zyz,01,clutter,01;
abc,zyz,02,clutter,01;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}