const regex = /\babc(?:,(?!02,)[^,;\n]+)*,01;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\babc(?:,(?!02,)[^,;\\n]+)*,01;', 'gm')
const str = `input1: "abc,clutter,01;xyz,clutter,02;" (should match)
input2: "abc,clutter,02;zyz,clutter,01;" (no match)
input3: "abc,clutter,02;abc,abc,txt,txt,01;xyz,clutter,01" (should match)
abc,zyz,01,clutter,01;
abc,zyz,02,clutter,01;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}