# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\babc(?:,(?!02,)[^,;\n]+)*,01;"
test_str = ("input1: \"abc,clutter,01;xyz,clutter,02;\" (should match)\n"
"input2: \"abc,clutter,02;zyz,clutter,01;\" (no match)\n"
"input3: \"abc,clutter,02;abc,abc,txt,txt,01;xyz,clutter,01\" (should match)\n\n\n"
"abc,zyz,01,clutter,01;\n"
"abc,zyz,02,clutter,01;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.