#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "1x|1.*"
Local $sString = "1x21y3333333313333"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)