using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1x|1.*";
string substitution = @"";
string input = @"1x21y3333333313333";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}