$re = '/1x|1.*/';
$str = '1x21y3333333313333';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;