package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?array\(('.*?)\), [^\)]+'\);.*`)
var str = `drupal_add_js(array('my_common' => array('my_code_validate' => variable_get('my_code_validate', FALSE), 'inner_index2 => 'inner_value2'), 'another_item' => 'another_value'), 'setting');`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}