$re = '/.*?array\((\'.*?)\), [^\)]+\'\);.*/m';
$str = 'drupal_add_js(array(\'my_common\' => array(\'my_code_validate\' => variable_get(\'my_code_validate\', FALSE), \'inner_index2 => \'inner_value2\'), \'another_item\' => \'another_value\'), \'setting\');';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;