#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^( # start group 1" & @CRLF & _
"\((?>[^)(\]\[}{]+|\g<1>)*\)| # parens" & @CRLF & _
"\[(?>[^)(\]\[}{]+|\g<1>)*\]| # brackets" & @CRLF & _
"\{(?>[^)(\]\[}{]+|\g<1>)*\} # braces" & @CRLF & _
")$ # group 1 end"
Local $sString = "{xyz}" & @CRLF & _
"{xyz]" & @CRLF & _
"{[]}" & @CRLF & _
"([foo]bar)" & @CRLF & _
"([{bar}]baz)" & @CRLF & _
"([{barbar]" & @CRLF & _
"((a)b)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")