using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^( # start group 1
\((?>[^)(\]\[}{]+|\g<1>)*\)| # parens
\[(?>[^)(\]\[}{]+|\g<1>)*\]| # brackets
\{(?>[^)(\]\[}{]+|\g<1>)*\} # braces
)$ # group 1 end";
string input = @"{xyz}
{xyz]
{[]}
([foo]bar)
([{bar}]baz)
([{barbar]
((a)b)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}