package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^( # start group 1
\((?>[^)(\]\[}{]+|\g<1>)*\)| # parens
\[(?>[^)(\]\[}{]+|\g<1>)*\]| # brackets
\{(?>[^)(\]\[}{]+|\g<1>)*\} # braces
)$ # group 1 end`)
var str = `{xyz}
{xyz]
{[]}
([foo]bar)
([{bar}]baz)
([{barbar]
((a)b)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}