re = /^( # start group 1
\((?>[^)(\]\[}{]+|\g<1>)*\)| # parens
\[(?>[^)(\]\[}{]+|\g<1>)*\]| # brackets
\{(?>[^)(\]\[}{]+|\g<1>)*\} # braces
)$ # group 1 end/mx
str = '{xyz}
{xyz]
{[]}
([foo]bar)
([{bar}]baz)
([{barbar]
((a)b)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end