using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(url=""[^""]+"")";
string input = @"<code url=""http://ns.adobe.com/textLayout/2008""><p>""test""</p></code>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}