re = /(url="[^"]+")/
str = '<code url="http://ns.adobe.com/textLayout/2008"><p>"test"</p></code>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end