const regex = /(url="[^"]+")/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(url="[^"]+")', '')
const str = `<code url="http://ns.adobe.com/textLayout/2008"><p>"test"</p></code>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}