$re = '/(url="[^"]+")/';
$str = '<code url="http://ns.adobe.com/textLayout/2008"><p>"test"</p></code>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);