#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d)?(?:\.\d{1,2})?$"
Local $sString = ".1" & @CRLF & _
".12" & @CRLF & _
"1.2" & @CRLF & _
"1.23" & @CRLF & _
"12.3" & @CRLF & _
"12.34" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
".12" & @CRLF & _
"1.229" & @CRLF & _
"345.56" & @CRLF & _
"1235678.1234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")