const regex = new RegExp('^(?:\\d)?(?:\\.\\d{1,2})?$', 'gm')
const str = `.1
.12
1.2
1.23
12.3
12.34
1
12
.12
1.229
345.56
1235678.1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}