// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d)?(?:\.\d{1,2})?$").unwrap();
let string = ".1
.12
1.2
1.23
12.3
12.34
1
12
.12
1.229
345.56
1235678.1234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}