package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d)?(?:\.\d{1,2})?$`)
var str = `.1
.12
1.2
1.23
12.3
12.34
1
12
.12
1.229
345.56
1235678.1234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}