using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d)?(?:\.\d{1,2})?$";
string input = @".1
.12
1.2
1.23
12.3
12.34
1
12
.12
1.229
345.56
1235678.1234
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}