#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?!.+\/)(.*\.jpg$)"
Local $sString = "/Volumes/Macintosh Data HD/WWW/Daytona/ inventory/ Yamaha/#0XVZ13B/2007xvz1300royalstarventurestk07xvz13b/wip/2007_XVZ1300_Royal_(1).jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")