$re = '/(?!.+\/)(.*\.jpg$)/i';
$str = '/Volumes/Macintosh Data HD/WWW/Daytona/ inventory/ Yamaha/#0XVZ13B/2007xvz1300royalstarventurestk07xvz13b/wip/2007_XVZ1300_Royal_(1).jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);