re = /(?!.+\/)(.*\.jpg$)/i
str = '/Volumes/Macintosh Data HD/WWW/Daytona/ inventory/ Yamaha/#0XVZ13B/2007xvz1300royalstarventurestk07xvz13b/wip/2007_XVZ1300_Royal_(1).jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end