import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.+\\/)(.*\\.jpg$)";
final String string = "/Volumes/Macintosh Data HD/WWW/Daytona/ inventory/ Yamaha/#0XVZ13B/2007xvz1300royalstarventurestk07xvz13b/wip/2007_XVZ1300_Royal_(1).jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}