use strict;
my $str = '/Volumes/Macintosh Data HD/WWW/Daytona/ inventory/ Yamaha/#0XVZ13B/2007xvz1300royalstarventurestk07xvz13b/wip/2007_XVZ1300_Royal_(1).jpg';
my $regex = qr/(?!.+\/)(.*\.jpg$)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}